fiat stilo speedo fault

Cars related to phrase fiat stilo speedo fault

fiat stilo speedo fault
fiat stilo speedo fault

Answers and questions: fiat stilo speedo fault

FIAT STILO 04 Stilo- Faulty speedo

Have a faulty speedo intermittent problems. Was told that it could be the related speedo sensor is it located around the gears Any help including diagram location of the sensor or other diagnosis would be apprecaited.

There is no speed sensor on the gearbox. The speedometer gets its signal from the ABS ECU which gets its signals from the 4 wheel speed sensors mounded on the wheel hubs.

FIAT STILO Speedo stopped working (after replacing corroded ECU)

Hi Told you all about the abs light and loose connection a couple of days ago. Still have that problem after checking all D4 connections. Have fitted new cam belt etc. Now the speedo has stopped working. Any ideas guys. Any help and advice on these problems would be appreciated before yet another costly trip to the fiat garage.

Did you mention anything about a new ECU in your previous post I had loads of faults back in 2006 on my 02 stilo 1.6 and I ended up getting a new ECU from fiat . Had all kinds of faults flashing like a christmas tree which wasnt traceable to earth electrics or battery. Then the speedo dropped to zero so we were guessing the speed. I found it quite fun but my wife wasnt very happy with the situation.

Hi again Yes we had a new ECU fitted at the fiat garage in June. We had a tyre specialist fit 4 new tyres last week. Leo (the hubby) has serviced the stilo including cleaning the front discs and fitting new pads. The ABS light came on on Thursday telling us loose connection. Then on friday he fitted new cam belt etc after which he checked the D4 connections and all seemed ok. So connected up the battery

Originally Posted by anbax1953 We had a tyre specialist fit 4 new tyres last week. Its highly likely the tyre fitter has damaged (possibly just wiring unclipped or dirt on sensor etc) a wheel speed sensor on one of the wheel hubs This will generate an ABS (also ASR of you have it) fault. Reading the fault code should prove it

Originally Posted by anbax1953 Hi again Yes we had a new ECU fitted at the fiat garage in June. We had a tyre specialist fit 4 new tyres last week. Leo (the hubby) has serviced the stilo including cleaning the front discs and fitting new pads. The ABS light came on on Thursday telling us loose connection. Then on friday he fitted new cam belt etc after which he checked the D4 connections and all seemed

FIAT STILO electrical fault

Ive got a fiat stilo 1.2 16v 6 speed the fault is when I turn on my headlights and the window wipers come on and flashes up on the speedo screen something about the indicator bulb and brake fluid low Brake fluid is on max and indicator bulbs are fine Would it be a fuse gone or something

Originally Posted by Dameincollings Ive got a fiat stilo 1.2 16v 6 speed the fault is when I turn on my headlights and the window wipers come on and flashes up on the speedo screen something about the indicator bulb and brake fluid low Brake fluid is on max and indicator bulbs are fine Would it be a fuse gone or something How is you battery condition You can get random faults showing up when your

FIAT STILO Non starter and Massive list of fault codes from ECUScan

Hey folks Wondering if someone could point me in the right direction with this before spending loads on the car (again) stilo Abarth 2.4 02 plate On Monday the car would not start just turning over and over and over. Removed and replaced small fuses under bonnet and reset ECU by removing the battery for a while. Started fine no issues until the Tuesday Same thing happened but it is refusing to start.

FIAT STILO Stilo reluctant to start - Engine Fault message

Hello there Ive asked technical questions on the Forum a long time ago regarding my stilo 1.4 Active (04 plate) but had to re-register as Ive forgotten my details I have been through everything that seemed similar but cant find an exact match for my current problem. First of all the car sat for about four and a half months without being even started. My bad...my husband had a stroke last September

Originally Posted by Hippyschick Hello there Ive asked technical questions on the Forum a long time ago regarding my stilo 1.4 Active (04 plate) but had to re-register as Ive forgotten my details I have been through everything that seemed similar but cant find an exact match for my current problem. First of all the car sat for about four and a half months without being even started. My bad...my husband

FIAT STILO stilo speedo stopped

stilo 1.2 2002 speedo not working. everything eles look like its working . done a lot of reading and from this forum.sencer is from the abs pick ups in hubs.. i dont have any abs faults etc. i do have 1 code U1601..(look up says key related or close). is there a way to test the speedo .

Originally Posted by vladof So now i assume the temp is not working is it You should try a scrapped one and finally fix it for good. temp dose work A BIT.. and for buying a scrap one..i needed to no if it was the clocks.. befor i part with a lot of cash. as thease clocks are go faulty a lot. this was about getting the speedo to work... but my trip lcd screen only give miles and time..(nacked) so the

FIAT STILO Speedo needle climbs to maximum

My speedo needle climbs to maximum then stays like it for a couple of days. It then falls back with repeated of switching ignition on and off ate the rate of about 5 mph each time. It behaves normal for a few days and then plays up again. It was normal for ages over the winter bu now it is getting worse and is wrong more than right. The other day I jet washed the wheel arches thinking that salt may

FIAT STILO warning lightsfault codesproxy alignment

Help Recently I went to start my fiat stilo 04 plate and the radio was dead i had it replaced with a 2009 fiat radionow my engine managementabshandbrake and yellow tiangle light is on and my speedometer does not work. I tried all the reset procedures but they dont work it looks like the two cambus wires were moved to different places to fit the stereo i am getting the following codes1-c1003(vehicle

i have the same problem however i dont know how my warning lights came on they just appeared and havent gone since also my speedo isnt working but rev counter fuel gauge and temp gauge all work along with the clock and trip computer i havent yet taken it to a garage but i have spoken to a mechanic who told me to get it hooked up to diagnostics machine and get the faults wiped as it tells me things

FIAT STILO where is the speedo reading from

Would anyone konw which wheel the speedo takes its reading from ive disconnected both of the front asr abs connectors and it still reads the speed trying to find a loose connection

YouTube - stilo loose connection fault YouTube - stilo loose connection fault this is whats happening..

Ben Im only guessing but in your position Id start looking behind the dash. I suspect it will be one of those jobs where you dont find the fault but when you put everything back it cures itself. Look for any earthing issues related to the instrument cluster and you might just see something up. Look on the bright side - you can cure those instrument rattles at the same time

if you remove your instrument cluster you might check the circuit board inside with a magnifier glass - sometimes there is corrosion on it which can cause all kind of strange faults ....... you can clean the surface with a toothbrush or something similar. i repaired a cluster this way which cut out several minutes after start-up... Steely thanked for this post

Id check the plugs as a largish gap will make the coils work harder and find an easier route home. If you have the old coils Id try substituting one at at time and see what happens. Intermittent faults are always the most difficult. Keep working on the clues RPM related engine only under load fuel air ignition

FIAT STILO stilo dash and speedo prob

Hi there Im new to this forum having purchased a 52plate stilo for my wife yesterday.I have a couple of questions that hopefully someone can help me with as i feel unsure of the car at the min. Firstly when driven at around 65mph i get the amber warning triangle and also audible beeps.What would cause this or likely problem SecondlyI didnt notice when i purchased it but the speedo does not return to

Right heres a quick update to my problemsThe speedo has been fine since i disconnected the battery.I have also found out why i had no menuIt seems that somtime in its life it has got an airbag failiure warning and instead of fixing the problem someone had put a strip of black tape accross the menuwarning line.I had a small fit at the person i got it from but they just pleaded ignorance I have now removed

Well thats absolutely fantastic. Who does things like this Whatss most common are the orange connectors under the front seats and the OCS mat. Check your passengers seat cushion for a tag that says OCS (like the tags that say Airbag). If you dont find it you dont have it - or the previous owner have ripped it off which might be an option. Easiest way is to hook it up to a computer to trace the fault line.

FIAT STILO Speedo not working

Boosted 1.9JTD manual as it had flat battery after being sat for some weeks. Then found that the dash wouldnt light up and no dials worked and it also blew a fuse which was replaced. Sent dash away for repairs came back with everything working except the speedo. Returned with car to Repairers who said the dash was working fine this has also been backed up by an auto electrician. Live data from both

FIAT STILO wheel bearing change abs fault

Hi guys I have just had the front wheel bearing changed on my stilo. Picked it up just as the garage was closing. Got down the road and the dashboard lit up like a xmas tree with constant beeps of abs ebd failure. Is it likely to be the sensor or the the ring that the sensor picks up I have plugged it in to multiscan and it is say both front wheel speed sensors

Surprising that fault should be both front sensors unless both bearings were changed. Common to a lot of cars the bearing contains the pulse ring for the speed sensor. If the bearing is fitted the wrong way around there will be no signal. Youd hope that all garages would be aware and careful about this but perhaps not. If this is the fault they might be able to turn the bearing around or it might need

FIAT STILO Loose connection ABS and speedo

Help My faithful stilo has suddenly developed the following symptons. The ABS light the brake warning light and the engine fault light are all illuminated. The speed does not work although the other instruments do. The engine power is reduced. The display says Loose connection I have pulled off and cleaned the connections on the ABS pump and the under bonnet fuse box. Any ideas

First thing I would do is check the battery. Make sure it is spot on as you would be amazed the amount of times the battery is the culprit with electrical problems. While you have the battery out remove all the chassis earths clean and make sure they are tight then perhaps unplug your fuse box and check all your connections there. Clean them all with contact cleaner and plug it all back together with

FIAT STILO strange elec fault

stilo 1.4 16 valve all ignition & warning lights come on for a couple of seconds speedo & rev counter go off have checked all battery & fuse connections even with ignition off & key out i can still hear a noise like interference or a short circuit when this happens the car does not cut out or anything it keeps driving as normal. any help is much appreciated.

FIAT STILO Speedo (sender) problems .....

Greetings .... Ive been through this loop before with instrument cluster failure - eventually curing the matter with a sh complete cluster unit. Problem solved. So Im quite familiar already with the usual problems. This one may be different. All the instruments in the cluster work except the speedo itself. When the key is put in the ignition the needle on the speedo jumps and settles on 0mph which

Theres one wheel speed sensor on the hub carrier of each of the four wheels however if one of the sensors was at fault or disconnected you should be getting an ABS fault code and a warning light andor message on the cluster. Id advise reading the fault codes before diagnosing by substitution.

FIAT STILO Electrical faults like blackpool illuminations on Stilo 1.6 Dynamic

Hi New Member here and novice to mechanics Really hope someone can help me . Bought a fiat stilo 1.6 Dynamic 5 days ago since then the warnings and lights have been swapping on and off galore ive had all sorts airbag failure engine failureloose connection alternator failedASR and ESP failure. Although i have all of these the car seems to be driving fine except once when the car said alternator failed

Originally Posted by keviwal Hi again Right you need a multimeter as Deckchair has explained im with deckchair on this one i reckon the battery is not being charged up enough (bucket ) If its any help i could meet you half way and lob my laptop on it to see if i can find anything. For me Oldham is around a 60 mile round trip and time is tight for me at the mo. Remeber it is going to be something simple

FIAT STILO rev counter and speedo malfunction

Need suggestions of what the issue is as this was dangerous last night . I was driving along the motorway and around town last night when it was raining. And the rev counter and speedo just went all over the place with it going all the way round on the dials and it coming up I was doing 150 mph when clearly wasnt then nothing and then 70mph when was stationary lol. It seems my car comes up with checking

this is probably a cluster fault - i can repair it for you for 65 pound plus 12 pound for the return shipping costs from Netherlands to UK.

FIAT STILO speedo cluster problems

hi i have a 53 plate stilo and the cluster containing the speedo odometer etc keeps losing power and the turning back on again. sometimes it will only be off for a split second and sometimes longer. Also sometimes if Im driving the cluster will turn off but leave the speedo at the current speed and then when it turns back on it thinks that is the zero mark. Has anyone had this issue before or anyone know what it could be and how i could fix it cheers Hix

Skiba - a proxy alignment does NOT adjust the mileage - it adjusts the behaviour of the instrument cluster according to the configuration of the body computer. Mileage can be adjusted upward with Examiner or FES downward with special equipment. I can repair these cluster faults for 65 pound plus 12 pound for the return shipping costs from the netherlands to UK. I also can adjust the mileage of donor

FIAT STILO Spring rates

I have a 1.2 stilo and plan on lowering it on coilovers. I have 15s on 18545 tyres and they look tiny in the stilo arches but from a previous photoshop I know they will look the business when the car is suitably lowered Ive done my measurements and I need a 100mm drop to take it to where I want it and thats leaving 15-20mm to the arch. Ive phoned around a few places and so far all Ive had is them saying

Originally Posted by MarkThompson4 How was my speedo 5-8% out before put the smaller tyres on s or is that taking inaccurate fiat technology into account Most speedometers are inaccurate. Mine is about 7% off constantly on summertires (2154517) - even after I changed my instrument cluster so the fault is not there. On winter tires (1956515) its about 6% off. Try testing yours against a GPS. Its not

Originally Posted by Morty Mort Most speedometers are inaccurate. Mine is about 7% off constantly on summertires (2154517) - even after I changed my instrument cluster so the fault is not there. On winter tires (1956515) its about 6% off. Try testing yours against a GPS. Its not a fiat special its quite common and very annoying but also a quality as it is difficult to maintain constant speed so if

FIAT STILO Instrument Panel having a party

Hey all Was driving down the M1 the other night when all of a sudden everything on my instr. panel (rev counter speedo all the dials trip computer etc) just died. A few seconds later where was a whirring noise and they came back to life only this time my speedo was registering that I was doing 130 mph and my rev counter told me I was sitting at around 700 rpm which on both accounts I blatently wasnt.

FIAT STILO Help Stilo 2002 1.6 engine cutting out

My fiat stilo 1.6 2002 is continually cutting out. Originally first saw the errors when arriving at work last Tuesday after a 32 mile drive. Did a number of times then was fine. Went and started the car at lunchtime and no errors. Drove home and same fault after 19 miles. Restarted and did it again 200 yards later. Called out the AA and could find nothing wrong when putting the computer on the car.

FIAT STILO very poorly 1.2 active 53 plate stilo

hi all I have a 53 plate 1.2 stilo. Left the house one morning to find the side lights constantly on and the stereo blaring out I left it to drain the battery which has now been replaced but there are several warning when turning the engine on such as Loose Connection Immobiliser fault ABS fault as well as no speedo no rev counter or mileometer. All warning lights are on on dash board and have to disconnect

FIAT STILO Instruments intermittent Checking

Hi all my wife has a 2002 fiat stilo over the last week it has intermittently displayed the Checking message on the dash instrument screen when starting the car. Where this would usually go off after a couple of seconds it seems to sometimes stay on and when it does none of the instrument dials work (revs speedo fuel etc..) Not sure what the fault is at first I suspected the instrument cluster was

FIAT STILO New gearbox problem 1.6 stilo

I previously posted regarding a gearbox failure on my 1.6 sport (54) which suffered from the seemingly common fault of the diff pin failing and ruining the diff casing. As a result i stripped the gearbox down had it completely restored including a replacement diff and diff casing. Fortunately this hasnt happened again... but i have an issue with my gearbox again. I have been using the car for a few

sure because i tried selecting gears using my hand on top of the box. Still the same issue. Either one of the selector gears is worn or something came loose inside the box and its out of alignment. Ill take it apart this weekend and see what i can see. Was your replacement gearbox from the same year Do you know if all mk1 stilo 1.6 gearboxs are the same The replacement gear box was ordered from fiat

FIAT STILO Stilo instrument cluster problem

I have a 55 plate fiat stilo 1.9 JTD and the cluster has failed which has been confirmed by a repair firm as being unrepairable. Ive read lots of threads saying these can be replaced has the second-hand cluster got to have exactly the same software and hardware versions as the original one I bought one from ebay from a stilo JTD and this doesnt work either. Is this because the software and hardware

FIAT STILO Body Control Module

Can anybody please tell me where the body control module is on a 2006 stilo JTD Would i be right in presumming that it is actually the fuse box behind the battery or is there another module somewhere Thanks in advance. Mick

of fuses tat ha gone green. I rebuilt it and did the proxi alignment and the fuel gauge started working and some of the warning lights went out. The car had been sat for 12 months when I bought it and I dont know if the faults have occurred since then or if they were there before. I have tried another instrument cluster but its from a 2003 and that doesnt cure the speedo or rev counter etc. The fiatECUscan

FIAT STILO Help with 2006 Stilo JTD Dash Please

Hello all. I wonder if anybody could try and help me with a little dash problem i have please I have just bought (a couple of weeks ago) a 2006 stilo 1.9JTD. The car has quite obviously been sat a long time and has not been used (at least a year i would guess). It has a dash problem that i am trying to sort out but it does not seem to have the same issue as others i have seen on here. Basically the

replaced the instrument cluster cleaned all the earth connections removed and cleaned every fuse and i even tried swapping a body control module (but it would not start due to the immobiliser). Still no better I keep getting the same fault code which is U1700 - CAN Body Computer conn fault (1) no signal Everything else now works fine except the speedo rev counter and temp gauge. If you use the fiat

replaced the instrument cluster cleaned all the earth connections removed and cleaned every fuse and i even tried swapping a body control module (but it would not start due to the immobiliser). Still no better I keep getting the same fault code which is U1700 - CAN Body Computer conn fault (1) no signal Everything else now works fine except the speedo rev counter and temp gauge. If you use the fiat

Hi Welcome to the FF. Theres a thread here about the Loose Connection message ABS fault and no speedo httpwww.fiatforum.comstilo26122...vent-fire.html . Babbo thanked for this post

FIAT STILO Living with a JTD

Hi all new to the stilo forum but regular on FF. currently looking at a stilo MW JTD 115 Active thats been offered to me from another member. if i get the stilo ill be coming from a Astra Coupe but what i want to know is what are they like to live with and use as an every day car. the main reason im looking into this is that i currently get 350miles maximum from the Astra wheras i know the JTD s can

3dr according to the computer (and yes i reset it each time i refuel). This doesnt sound great but i never get less than 500 miles out of a tank and often get between 530-560 so i wonder (without bothering to do the sums) whether the trip computer is abit pessimistic. I havnt done the sums for ages because the official combined is 53.3 and 500-560 to a tank seems perfectly acceptable to me. The stilo

FIAT STILO CAN Bus wiring help please

Im in desperate need of some help from anybody that has CAN Bus experience please The car is a 2006 stilo JTD and it has a cluster fault. I have tried a cluster engine ECU body computer fuse box and I have cleaned all the earths. I cant get the speedo rev counter or temp gauge to work. I have checked the fault codes with FES and the fault thats showing is CAN communication error between the engine

FIAT STILO Fiat Stilo 54 plate Instrument Cluster.

The dashboard on my stilo has stopped working ( no speedo rev counter petrol gauge back lights etc etc) it works very intermitintly it has not worked for the past week now but worked for 2 whole days prior to that i have had the fuses checked and apparently they are ok any help on finding the fault would be greatly appreciated. Rikki

Ask an expert